Icom 7610 HDSDR and Icom I/Q Package

K0PIR

I'm an Amateur Radio enthusiast. I love the hobby and experimenting with radios, antennas and software. On my YouTube channel I upload videos on the Icom 7300 and Icom 7610 along with Ham radio software programs. I hope to inspire people to try new things in Amateur Radio.

30 Responses

  1. blank Brad says:

    So no need for a SDRPLAY like device? Wow!

    • blank K0PIR says:

      Hi Brad,

      That’s correct, just a USB 3.0 cable. It’s a very nice addition and very clean. I was surprised there is no need for OmniRig and I think that’s a big plus. So far everything is working very good.

      I’ll have more when I get back from my trip.

      Best 73,
      Rich, K0PIR

  2. blank Rob says:

    Presumably one has to use a pc with a usb3 port?
    will a standard usb2 cable not work with a standard usb2 pc?
    73
    Rob
    G3RCE

    • blank K0PIR says:

      Hi Rob,

      Nice to hear from you.

      Yes, they don’t have it for the MacOS. I’m using a Windows PC.

      I have heard Hams using a USB 2.0 cable, but I have not tried it myself. They say it works good.

      Best 73,
      Rich, K0PIR

  3. blank Brad says:

    I have it all setup and worked right away thanks to your work.

    When I click on the HDSDR waterfall, it moves the waterfall to center the freq I clicked on cuasing break is the waterfall. Have not found a setting to fix that. Do you know what it is?

    Thanks,

    Brad

  4. blank Anonymous says:

    I followed your video instrucions and I now have HDSDR working seamlessly with my IC-7610, thank you. Now neded to work on CW Skimmer. When’s that video going to appear? No pressure. 🙂 Ian G4YVZ

    • blank K0PIR says:

      Hi and thank you so much for posting your comment and question. I am working on it at the moment. There is a CW contest coming up and I hope to have it going this weekend with some results.

      Thank you and best 73! – Rich, K0PIR

  5. blank Ian Cooling says:

    Hi Rich
    Thanks for the CW Skimmer video. Everything working as it should. Seamlessly. Great integration between the IC-7610, HDSDR and CW Skimmer. I would never have managed that without your invaluable help . Within a week I’ve doubled the capabilities of the radio. Again, a big thank you. Ian.

    • blank K0PIR says:

      That’s fantastic Ian and thank you for commenting.

      I was on 40 Meters this morning and saw about 180 stations on CW using 170 kHz wide. Wow!

      That’ll be next.

      Best 73,
      Rich, K0PIR

  6. blank Dennis Baker says:

    I have been through the set up process many times with the ICOM document and your video and have not been able to get N1MM and CWSimmer working at the same time. I can use one or the other, but not both. I have been on the phone with ICOM Tech Support and submitted a support request, but have not found a solution so far.

  7. blank K0PIR says:

    Hi Dennis,

    Nice to hear from you and that doesn’t sound good, but at least you know both are working, just not together huh?

    Are you having an issue with conflicts and rig control?

    In my setup I am using a separate CI-V cable for CWS and OmniRig, however Icom says to use Kenwood. Which are you doing?

    Did you see this article? 24kHz CW Skimmer Icom 7610

    Tell me more.

    Rich, K0PIR

  8. blank Cyrus Turner says:

    Hey Rich,
    I have a problem loading the IC-7610 USB I/Q Package.
    It downloads but when I double click setup 64bit It starts the process then stops. Starts saying it cant find a HDSDR package installed. any ideas? I had this working on the same computer but switched to a SSD this week end and now I get this message. Everything else has loaded. including the Uart Codec drivers.
    I have already downloaded and installed HDSDR. Any help will be greatly appreciated.

  9. blank K0PIR says:

    Hi Cyrus,

    Nice to hear from you and thanks for commenting.

    Do you have the latest HDSDR? See if you can open HDSDR. Restart the PC and try installing the Icom I/Q.

    I would uninstall HDSDR and do another install of it, then try the Icom I/Q install again.

    Rich, K0PIR

    • blank Cyrus Turner says:

      Rich,

      This is the error message I receive:

      The set up has detected no version of IC-7610 USB I/Q Package has been installed.
      The specified command-line options require that the application be installed to continue.
      The set up will now terminate.

      At a loss here
      Cheers
      Cyrus / W5DXE

    • blank Cyrus Turner says:

      Morning Rich,
      Well Not sure why but HDSDR and IQ package took to the new laptop like a duck to water. everything seems to be as it should. Mainly it finally installed. Ill let you know if I find anything else out. Going to do a full reload of the OS on the desktop to see if that may be the issue.
      73
      Cyrus/W5DXE

      • blank K0PIR says:

        Yes, that’s great. It must have something to do with the other install. I don’t know what it could be though.

        Please let us know if you find anything.

        Thanks for commenting Cyrus.

        73,
        Rich, K0PIR

  10. blank K0PIR says:

    I guess I am not sure when you are getting that error. Is it during the I/Q package process?

    With the I/Q package installed you should see IC-7610 I/Q OUT Port in the device manager under Universal Serial Bus Controllers. Do you see that?

    If you are using the 64-bit .exe of I/Q package, are you positive you have installed 64-bit Windows? – Rich, K0PIR

    • blank Cyrus Turner says:

      Yes it is during the I/Q package installation process. Yes I am running Windows 7 Pro Ultimate 64 bit.
      Still scratching my head over this one. I uninstall everything after failure. IE: HDSDR, the I/Q Package. and still no dice once it is re installed. Nothing at all on device manager. It never gets that far.

      • blank K0PIR says:

        Oh, so it’s not getting installed for some reason. Did you try installing the HDSDR 32 bit .exe?

        Rich, K0PIR

        • blank Cyrus Turner says:

          Yes but it wont let me. It says install 64 bit file which I have several times but to no avail. I have even gone as far as uninstalling the CP210X UART bridge drivers and reinstalling them. No go. Rich I do notice that the ICOM 7610 High Speed FIFO bridge isn’t installing either.It shows in the device mgr but says no driver found. Does this have any bearing on my trouble with the I/Q package?

          • blank K0PIR says:

            Hi Cyrus,

            I don’t think so, but it is an indication something is amiss. Have you tried the install using Admin, right click and “Run as administrator” when installing the file?

            Rich, K0PIR

          • blank Cyrus Turner says:

            Yes that was the first thing I tried. I’m getting a new Laptop this week and going to see if it will take the install. If it does Ill use the laptop to control the 7610 and my other radios. And just use the desktop for other stuff. Ill let you know how it turns out. Just cant figure why it only refuses to install this application. Everything else loads and installs without issues.

          • blank K0PIR says:

            It is odd and please let me know the outcome.

            Thanks Cyrus.

            Rich, K0PIR

  11. blank Rien Aarden says:

    HI Rich

    I’m work with the IC-7610 and Microham MK3 so is it than also possible to work HDsdr with the USB3 Cable
    Tnx for the nice video’s Rich
    73′
    Rien, PA7RA

  12. blank K0PIR says:

    Hi Rien,
    I am not familiar with the Microham, but I don’t think you will have a problem. It should work fine like any keyer I think.

    I have one USB2.0 cable (rig control and data) and one USB3.0 cable (HDSDR) attached to my 7610. I also have a CI-V cable attached and I use it for some software. Then there’s my DB9 serial cable I have attached to the rear of the 7610 for CW. I use it with HDSDR, CW Skimmer and N1MM Logger+.

    Thanks for coming by and visiting, and it’s nice to hear from you.

    73,
    Rich, K0PIR

  13. blank Antonio says:

    Hi Rich , Also I can not install the IQ USB drivers from Digital Signature error, I tried several times to install but without success. Do you have any suggestions?0

    • blank K0PIR says:

      Antonio,

      Be sure to extract the .zip file all the way. If it is not extracted and folders created, I/Q package will not install.

      Rich, K0PIR

  14. blank Roldan says:

    Ive follow everything for the setup and configuration, The procedure entry point InitializeCriticalSectionEx could not be located in the dynamic link library KERNELL32.dll

    • blank K0PIR says:

      Hi Roldan,
      Nice to hear from you.
      Sounds like a Windows error.
      I am out camping and don’t have access to my home computer and rarely have access to the internet.
      Try the ICOM7610 Groups.io forum. Someone there has probably had the identical problem and you can find the answer quicker.
      Good luck, best 73!

  15. blank Roldan says:

    Thanks Rich will try to look on the forum.

    73,

    de Roldan VA6RB

Leave a Reply

You have to agree to the comment policy.